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Since 2002, Target Skills developed scheduling and planning tools that are used worldwide by more than 

4500 clients, including building companies, administrations, industries, IT.  

 

Track time and tasks assigned to your employees but also manage rooms, facilities, projects, 

appointments, meetings easily.  

 

Networkable, highly adaptable, our planning solutions provide an accurate global view of your human and 

material resources and improve productivity and efficiency.  

 

This manual describes all features within the software PlanningPME. 

 

 

 

Set the data of your planning 
 

Vocabulary used in the software 

 

What is a human resource? 

A human resource is a physical person: an employee, a technician, a manager, ... 

 

What is a material resource? 

A material resource can be several things: a room, a car, a computer, or any material you need to 

manage. 

 

What is an event? 

An event is a mission, a work to do by a human or material resource. 

A task is represented by a colored rectangle on the schedule. 

A task can be: an appointment, room booking, training, or anything specific to your activity. 

 

What is an unavailability? 

An unavailability is a day off, a period when the resource is not available. 

An unavailability can be: holidays, days off, illness, ... 

 

What is a resource "to plan"? 

The resource "To plan" is a post-it. Each event assigned to a resource "To plan" will appear on the schedule 

whatever the visualization mode (daily, weekly...) and the date. 

 

What is a department? 

A department is a group of human and/or material resources 

A department can be a technical, sales service in a company. 

Then, you will filter the schedule by department in order to display the resources of a department on your 

screen. 
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Resources 
 

You have the possibility to add as many human and material resources as needed. The different types of 

resources: 

Human resources (employees name, employee function, teachers...)  

Material resources (cars, rooms, equipments...) 

Resources "To plan" (For events not assigned to resources yet) 

 

Then, we are going to explain how to: 

Group those resources by department 

Group those resources by team 

Enter hours and job contract for each employee 

 

Create resources 
From PlanningPME, go to the menu "Data" -> "Resource" 

The list of all your resources appears. 

To create a new resource, press ”Add”. 

To modify it, select the resource and then “Modify” or double click on the resource name. 

To delete a resource, select the resource and then “Delete”. 

  

 
From the resource Window, you can add all those information: 
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Label 

This label will appear on the planning board. 

 

Resource type 

Choose if this resource is human, material or "To plan". 

 

Human resource 

 

Material resource 

 

"To plan" resource 

 

 

Hide this resource 

Note that you have the possibility to hide a resource when your resource is not part of the company 

anymore ticking on this option in order to keep track of the history. 
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Other information 

Choose a color for your resource. 

Assign the resource to a department. 

Etc… 

 

So, you can create as many human and material resources as you want in a very simple way. 

 

Display one or more resources on the screen 

You can display the planning of one or more resources from here: 

 
 

 

Zoom on resources of the type “To plan” 

 
 

What is it used for? 

The resource “To plan” is like a reminder and shows all events waiting to be allocated. 

You can have as many events as you want on resources of the type « To Plan ». 
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Floating 

Each event assigned to a resource "To plan" will appear on the schedule whatever the visualization 

mode (daily, weekly...) and the date. When you know who is going to complete the job, you will be able 

to move it via a "Drag and Drop".  

 

Fixed 

The events on the planning appear only on the planed dates and you can have several events at the same 

time: 

 

Height 

For a better visualization of your events to be planned, you can change the height of “To plan type 

resource from the card or directly from the screen shifting the bottom line. 

 

 

Display a panel: have your events listed 

You can have the list of all your events to be planned on a panel as shown below: 

 
Order your events via the different fields shown and then assign them to your resources via a drag and 

drop directly. 

 

 

Departments 

 
Group resources by department 
 

You have the possibility to create departments, as an example: Sales department, Account department, 

Technical team... 

From your entire schedule, you can extract the schedule of one department for a better visibility. 

 

Create departments 

From PlanningPME, go to the menu "Data" -> "Department" 
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Click on “Add” and give a label to your department. Then select the resources for this department and 

save. 

 
 

You can add as many departments as you want following the same procedure. 
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Moreover, to save time, with a right click, you can select or unselect all resources selecting the double 

arrow. Then, close this window and go back to the screen display. 

 

You can add a resource to a department directly from the “Resource” window. 

  

 
 

Proceed the same way for all your resources. You can assign your resources to several departments. 

 

Display one or more departments on the screen 

You can filter by one or more departments from those filters: 
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Resources order by department 
 

From the menu Data -> Department 

To change the resources order, go to the menu Data -> Department. 

The order is different for each department. 

Change the resources order via a drag and drop or clicking on the top of the column name and press the 

button “Save order”. 
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Drag and Drop from the screen 

You can also change the order of your resources directly on the screen. 

 

 
 

Time Profiles 

 
Create time profile 
Got to the menu Data -> Time profiles. 
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You can create as many profiles as needed. 

 

Here is the procedure: 

- Click on the button « Add » 

 
- Enter a name for your new profile and fill in the slots information 

- If your employee attendances are the same one week to another, tick on « Define work capacity in 

function of slots ».  

- If your employees working hours change from a week to another, tick on « Define the capacity in 

function of number of hours».  

 

You can create specific weekly slots for each employee. 

Visually, on the schedule, greyed days will correspond to non-worked days. 

 

Assign a time profile to a resource 
Open the card of the resource, go to the tab “Slots” and select a profile. 
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On the example below, Jean Marc do not work on Wednesday. 

 
 

Job contracts 
 

Go to the tab "Timetables" in the resource card. Put your mouse in a blank space in the contract table and 

right click on the mouse. Then select "Add". 

 

Enter a name for your contract: Ex: FULL TIME, PART TIME etc … 

Choose a beginning date for your contract and an ending date if needed. 

 

For each resource, you can create a specific contract. 

On the schedule, the non-working periods appear in grey.  
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Skills 
 

Create and assign skills to your resources and to your tasks depending on your activity. 

Allocate a task requiring specific skills to resources with those specific skills. 

You can look for skilled resources available for a mission. 

 Manage easily skills of your resources 

 

How to create domains and skills? 
 

First, create specific skills depending on your activity. 

From PlanningPME, Go to the menu “Data” -> “Skill" 

 

You can create different domains and skills. 

One domain is composed of several skills for example the domain “Language” is composed of the skills 

“English”, “French”… 

  
 

 

To create a field, put your mouse on a blank space of the window. Click on the right button of the mouse. 

Then choose “Add a domain” 

Type a name to your field. Then “save". 

 

Select the domain where you want to add your skill  then “right click” with your mouse and select “Add a 

skill”. Type a label. Then “save". 

 

 

Following the same process, you can create as many domains and skills as wanted. 

Modify or delete a skill, right click on it and select “modify” or “delete”. 
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Assign skills to your resources 
 

You can assign skills to your resources in just some clicks. Here is the way to proceed: 

Open the card of a resource and go to the tab "Skills". 

Click on the button "Assign skills" and make your selection. 

 

Assign skills to your tasks 
 

From the menu "Data" -> "Task", open the task card and assign skills clicking on the button "Assign. 

 

 

Check for skills adequacy 
 

Once your skills assigned to your resources and tasks, the software will check the skills adequation 

between tasks and resources. 

  

 

Filter skilled resources on the planning board 
 

To extract from the schedule skilled resources, you can play with the filter "Skill" at the top left side of 

your screen.  
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Tasks list 
 

Customise your list of tasks 
 

From PlanningPME, go to the menu “Data” -> “Task”  

From this menu, you can find all the labels already created. 

 
 

To add a new label, click on "Add" and type a new label before saving. 
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Then, you have several options available to customize your tasks. 

- Define the label 

- Change the text and background colors 

- Assign to specific departments 

- Assign hours  

- Assign skills 

 

 
 

Events category 
 

For each single event created on your schedule, you can assign a category. As an example, you can tell 

whether an event is important or not, if a booking is confirmed or not. 

Then, you can filter the schedule to have events of a certain category displayed.   

 

Define the list of categories 
 

From PlanningPME, go to the menu "Data" -> Category" 

 
 

To add a category, type a label, then select the text and background colors and press the button “Add”.  

You can also select hatching for the category. 
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NB: Each event created on the planning will be by default of the first category of the list.  For example, 

“Not Confirmed” in the example below. 
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Assign a category to an event 
 

A category may be assigned to each event created in the schedule. This can be modified by a simple right 

click on the event. With the use of hatching the categories may be more easily visible on the screen. 

 
 

Fast change of the category for several events of one resource 
You can change the category of several events assigned to a resource via a right click on the resource and 

then “Category”. 

 
Then, this window will appear: 

 
All events included between the dates selected will have their category changed in one shot. 

 

Have the category displayed on the schedule 
 

1- If you have added some hatchings to your category, you will see them directly on the planning: 
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Here, you have a double information: The color is the color selected for the task label and the haching 

represent the category of this event. 

 

2- You can display events in function of the color of the category on the screen from the menu 

"Tools" -> "Options" -> "View" -> Color depending on Category. The background color of the event 

will then be the color of the category of the event. 

 

3- You can also filter events of one particular category from the filter at the top right-hand side 

corner. 

 

 

 

Unavailabilities list: Absences, vacations, leaves 
 

You can manage days off (holidays, illness...) of your employees and non availabilities of your material 

resources. A report shows you your employees’ days off: which type of days off, the number and the days 

remaining. 

 

Customise your list or unavailability 
 

Pre-recording of the unavailibilities list 

From PlanningPME, go to the menu “Data” -> “Unavailability”  

Click on the button « Add », select  the label of your unavailability the color and save it. 
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Visualise your days off 
 

Visualise all your employees leaves 

Open the card of one of your resource and go to the tab « Unavailability ». The list of all leaves of each 

employee for each year can be visualized: 

 

 
 

To know exactly when your employees were off, click on the line and select button “History”. 

 

Counter: You can put a visual counter for each label. 
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General Setting for the count 

Go to the menu « Tools » -> « Days Off ». 

Fill in the information depending on your activity. 

  
 

Beginning Days Off: From which day are calculated your days off? For most of the company, the first day 

for the calculation is the 1st of January. 

Days Off on: On 5 or 6 days? 

If, for example, you select 5 days and that your employee is on vacation during 3 weeks, there will be 15 

days counted. 

Number of days off / Label for days off: Filling that two information will add a counter by default for all 

your resources for the label selected. 

 

Events status 
You can manage your own public holidays from the menu Data -> Public holiday 

Definition 
For each event of the schedule like a task or an unavailability, you will be able to specify a status. 

For example, you will be able to precise: 

if a day off is in the “on request” or “validated” status 

  

 

- if a meeting is in the  « Not started »  or « Finished » status for example 

  

 

A status is represented by a coloured vertical bar to the left of the event rectangle. 

The list of the task and unavailability status is entirely customized according to your business. 

 

How to activate the status ? 
To begin with, activate the option in the menu Tools -> Options -> Event and select what you want to 

activate : 

- Activate the status for the tasks 
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- Activate the status for the unavailabilities 

 

Customize your status list 
You can define two list of distinct status directly from the menu “Data”: 

- Task status: customize your status list for the event such as “Tasks” 

- Unavailability status: customize your status list for the events such as “Unavailabilities” 

 

 
Define the label and text and background colours. 

You can also specify the status by default when creating a new event on the schedule. 

 
Assign a status to an event 
For each event created on the schedule, you can also assign a status to the event. 

Then, you will be able to modify it with a simple click on the event: 
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Filter the schedule by status 
You can also use the filters “Task status” and “Unavailability status” at the top of your screen to filter the 

events in the schedule 

Refer to the chapter Filters in the schedule. 

Access right management 
Refer to the Rights Management chapter 

 Rename "Task status" and « Unavailability status » with your own words 
From the menu « Tools » -> "Labels and formats", you have the possibility to rename these labels “Task 

status” and “Unavailability status” with your own words. 

 

 

 

Public holidays 
 

You can manage your own public holidays from the menu Data -> Public holiday 
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Then, you will see them on the planning board with a different column color: 

This color is the one you selected for “Public holiday” from the menu Tools -> Options -> Display 

 

 

 

Clients 
 

You can manage your clients within PlanningPME. The number of clients is not limited. 

 

If you already have a client database, it is possible to import it in PlanningPME in order to avoid double 

typing all the information. Target Skills can develop some scripts to do this import or you can use the 

function to import from a txt file from the menu File -> Import -> Client. 

 

 

Activation of the option 
 

First of all, go to the menu “Tools” -> “Options” ->” Data" and select the option “Activate customers”. 

Select the type of your clients (Individual or Company) and the number of clients by event and then save. 

You now have a new feature “Client” from the menu “Data”. 

 

Add, modify and delete clients 
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Go to the menu “Data” -> “Client”. 

You can add, modify, hide or delete your clients from here. 

Here are all the details you can add for each client: 
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Import your client’s database 
 

In order to save time, you can import your client’s database from the menu: File -> Import -> Clients.  

Check the “Import” section to know more. 

 

 

Projects 
 

With PlanningPME, you can manage your projects and if needed, your subprojects specifying for each 

event the associated project. 

 

Activation of the option Project 
 

From the menu Tools -> Options -> Data, activate the option: "Activate Projects”  

 

 

Add, modify and delete projects 
 

From the menu “Data” -> “Project” you can add, modify or delete your projects from here. 

Here are all the details you can add for each project: 
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From the “Project” icon within the event window 

While creating a new event on the schedule, you can associate a project to this event. 
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While creating a new event on the schedule, you can also create a new project directly via a 

click on the “Project” red icon: 

 

The project card will then open and you can create a new project. This project will be added on your list 

of projects and you will be able to select this project directly next time: 

 
 

Once the project selected, from this icon, you can open the card of the project and make modifications if 

needed. 
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From the “Project” view 

 

Right click on left column and select « Add Project». 

  
You can also open the card of your project and delete it from here. 
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Search for a project 
 
Search from the “glass” icon in the event window 

While creating a new event, you have a search on your projects in order to save time when you have a 

long list: 

 
 

Clicking on the “glass” icon, you will then have this search window: 

 
You can make your search on the name of the project. 

 

Search from the project view 

Type a part of the name of your project and the planning board will be filtered rapidly: 
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Search from search window (Edit -> Search or CTRL + F) 

Type a part of the name of your project and all the events will be listed: 

 
 

Hide a project 
In order to keep track of the past events of one project without seeing it on the planning board, you can 

hide it: from its card or right clicking on his name and then « hide ». 
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Delete several projects 
 

You can delete several items from the menu Data, with the keys CTRL + DEL 

You will have a message asking you if you want to delete the items. 

 

Assign your projects to a client 
 

It is possible to assign several projects to one client. To do so, on the project card, you have a drop-down 

menu:  

 
 

NB: To adapt the project filter as described below, activate the option on the menu Tools -> Option -> 

User. 
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Results when filtering by client 

While filtering by client, only projects associated to this client will appear on the project filter. 

 

Results while creating a new event 

If you select one client first, projects associated to this client will appear on the project list. 

If you select a project first, the client will be selected by default on the client list. 

 

From Version 4.1. Assign your projects to a department 
 

It is possible to assign a project to a department. 

 
 

Then, when filtering by department, only projects associated to this department will be displayed on the 

drop-down list. 
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Tab Events: follow up of events allocated to a project 
 

From the project card, you have a tab “Events” that lists all the past and future events allocated to this 

project. 

  
 



 

Tutorial PlanningPME Desktop version  - 46 - 

 

History on the project creation and updates 
 

From the project card, you have a link “History” at the left bottom hand side corner of the window that 

list information about the project creation and modifications: 

 

You know who created this project and when and who modified it: 

 
 

 

Manage subprojects with PlanningPME 
 

You can associate subprojects to a project. This add a level to the software if needed. 

 

Activation of the option SubProject 

 
 

Add a subproject 

Open one of the projects. You now have a tab “Subproject” where you can add some 

subprojects. 



 

Tutorial PlanningPME Desktop version  - 47 - 
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Assign a subproject to an event 

When creating an event, you can now select the project and the subproject associated: 

 

 
 
Options around “projects” 
 
Customization of the terms "Project" and "Subproject".  

In order to adapt PlanningPME to your activity, you can rename the label "Project" and "Subproject" from 

the menu "Tools" -> "Language" 

 

Add additional fields on the Project window. 

You can create additional fields on the Project window. Check chapter on Additional fields’ creation. 

 

Colours in function of a project 

You can now display the colours of the boxes on the screen in function of the project colour. 

To activate the option, go to the menu Tools -> Options -> View and select Colours depending on 

“Project”. 

 

Events dependencies – Gantt diagram 

You can link your events to manage your projects efficiently. 

 
Read chapter on events dependencies to know more. 
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Manage your events and unavailabilities 
 

We will describe here all the features available while creating your jobs on the planning board: create, 

modify, delete events/unavailabilities, copy/paste, etc… 

 

Create your events or unavailabilities on the schedule 
 

On the schedule, an event will be represented by a coloured rectangle and unavailability will be 

represented by a hatched coloured rectangle. 

 

 
 

 



 

Tutorial PlanningPME Desktop version  - 50 - 

 

Create an event 
 

Different possibilities are available to create an event on the schedule: 

 

Draw a rectangle on the schedule with your mouse 

 

Via a Double-click 

Double click on a blank space of the planning board. 

 

Via a right click 

Go on a blank space of the schedule, click right on your mouse and select "New task". 

 

Go to the menu Action -> Task 

 

- With the shortcut CTRL + N 

Then, the following window appears: 

 
Type a text in the label or select one on the dropping list. 

The label are saved on the menu “Data” -> “Task” 

Then, select the dates and hours for this task and save it clicking on OK. 

A coloured rectangle appears on the schedule.  
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Intuitive typing of the tasks label 

 
 

When typing the beginning of a task label, the program now suggests some of the labels pre-registered in 

order to save time. 

 

Create unavailability 
 

Different possibilities are available to create it: 

 

Draw a rectangle on the schedule with your mouse 

Draw a rectangle on the schedule with your mouse pressing the key "CTRL" 

 

Via a right click 

Go on a blank space of the schedule, click right on your mouse and select "New unavailability". 

 

Go to the menu Action -> Unavailability 

In all cases, the following window appears. You just have to select your unavailability and enter dates and 

hours the same way as when you create event. 
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Type a text in the label or select one on the dropping list. 

The label are saved on the menu Data » -> « Unavailability » 

Then, select the dates and hours for this unavailability and save it. 
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Results on the screen: 

 

 

The unavailability appears with hatchings. 

 

Panels to create events and unavailabilities with a drag and drop 
 

You can create events and unavailabilities easily just via a drag and drop from the panel to the planning 

board. 
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Activate from the menu Data 

You can activate the panel for list of tasks, unavailability, templates, tasks to be planned from the menu 

data. Click on the button “Show the panel”. 

 

 
 

 

Activate from the menu “View” 

You can display all the panels available and then close those you do not want to show. 

 
Depending on your settings and your use of the planning, it will be interesting for you to use them all or 

only one or two of them. 

 

Below some videos: 
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Create your events easily via the panels 

http://www.youtube.com/watch?v=gEZBGcyOpR8 

 

Manage your events "on hold" or "to plan" easily 

http://www.youtube.com/watch?v=NjZsZvF7vEE 

 

 

Force the creation of an event  
 

Even if the resource is already busy 

You can now force the creation of an event even if the resource is already busy. 

You will have this kind of message below. 

 

 
 

 

If you press “Force Assignment”, the event will be created and you will have two events on the planning 

as shown below: 

 

http://www.youtube.com/watch?v=gEZBGcyOpR8
http://www.youtube.com/watch?v=NjZsZvF7vEE
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Otherwise, the event will not be created. 

 

NB: If you are already a client and that you are using the users rights, this feature will not be activated by 

default so that the users will not have this permission.  To activate it, go to the menu Data -> Group and 

tick on the box “Force assignment”. 
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Even if the resource is not skilled 

You can now force the creation of an event even if the resource is not skilled. 

 

First, assign a skill to a task from Data -> Task. 
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On the example above, we assign the skill Excel to the task “Training ”.* 

 

Then, on the planning, we try to allocate the task “Training” to a resource that do not have the skill 

“Excel”. 

You now have this message: 

 

The task will then be created. 

NB: If you do not want your users to use this function, you can give this permission from the menu Data -> 

Group 
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Copy / Paste 
 

Copy/Paste one event or unavailability 

Select the event or unavailabilities, right click and select “Copy” (CTRL + C). Then paste it via a right click 

and “Paste” or CTRL + V. 

 

Copy/Paste several items of a resource to another 

When several of your resources have the same activity (same hours, same events on a period time), you 

can copy the activity of a resource and paste it to another resource. 

Create the schedule of one of your resources first. 

Display the period you need to copy and paste (week, month…) 

Place your mouse on the resource, right click and select « Copy the activity » 
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Place your mouse on the other resource and click on the right button of your mouse and select « Paste the 

activity ». 

 
Thanks to this function, you will save time avoiding creating similar schedule several times. 

 

Copy/Paste several items via the selection Mode 

Via the selection Mode, you can select several events and then copy and paste them. 

NB: you can copy and paste only on the time axis: Indeed, the events will be copied to the same 

resources. Only dates will change. 

Assign an event/unavailability to several resources 
 

You can assign an event to several resources at a glance!  
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Create Multi-resources events  

From PlanningPME, create an event on the schedule. 

On the « Event » window, choose the tab « Resources » or tick on the box “Several" resources. The 

following window appears. 

 
 

The single arrow button allows you to select resources one by one 

The double arrows button allows you to select all resources of the left window in one click 

For a multi-selection, click on the name of the resources + touch CTRL before clicking on the single arrow. 
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Point 1: Filter resources by department or by type 

 
 

You can then assign the event to one or more resources of this department. 

 

Point 2: Display only available resources 

Selecting this box, you will avoid a double-booking. You can only select available resources on the period 

chosen. 

NB: if you have a lot of resources, this option can slow down your system. 

 

Point 3: Display only resources under contract of employment 

This is another filter. 

 

So, you can assign event to one or more resources easily. 

 

Separate Multi-resources events  

You can divide events assigned to several resources to assign it to one resource independently to the 

others. To do so, select the event, click right and select “Separate”. 
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Then, you will be able to modify the event for the resource selected. 
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Create periodical events 
 

A periodical event is an event that is repeated on the time at regular intervals. 

You can create recurrent events in order to save time. The function “Recurrence” will help you manage 

monthly meeting, yearly appointments… 

 

Create a periodical event 
 

When creating an event, in the window “Event”, click on the button “Recurrence”. 

  
The following window appears: 

Enter the beginning and ending hours for this event or select "All day". 

Choose the frequency: Daily, weekly… and days when this event takes place. 

Enter the ending date for your event and save. 
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Visualization on the planning board: 

 

 
 

Daily recurrence 

 
 

Weekly recurrence 

 
 

NEW!!! From version 4.1. Monthly recurrence 

 
You can select either one day in the month or select for instance the second Monday of the month. 
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Yearly recurrence 

 

Delete an occurrence or delete the series   
 

You can delete an occurrence of a periodical event or delete all the series. To do so, select the event and 

right click on the mouse. 

 

 
 

Then, clicking on « Delete », this message will appear: 

  
If you want to delete the selected event only, choose « the occurrence ». 

If you want to delete all the series, choose « the series ». 
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Get off the recurrence one or several events 
 

If you want, you can get off an event from its series either to: 

- shift it   

- activate a reminder only on this event... 

 

-> To get off one event from the recurrence: 

 
 

Select "Get off the recurrence". 

-> To get off several events from the recurrence: 

You can extract several events from the recurrence: It is useful when a person is on holidays. 

To do so, click right on the resource and select "Get off the recurrence". 

 
 

Select the period during which you want to get off the events from the recurrence. 
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Be careful: The period of time displayed on the screen must include the period during which the resource 

is off. 

Events are then independent and you can reassign them to other resources or delete them. 
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Modifications of events and unavailabilities  

 

Shift an event or unavailability on the schedule 
 

Via a Drag and Drop 

Select the event or unavailabilities and shift it via a drag and drop directly on another resource and/or on 

another date. 

 

Open the window 

You can also open the event or unavailability and change the dates and/or resources directly. 

 

Shift several items via the selection mode 

Creation mode This mode allows you to create events on the schedule drawing a rectangle or double 

clicking. 

Selection Mode This mode allows you to select several events at the same time and to move them on the 

scale time. 

 
While going to the “Selection” Mode, you can shift your events. After your action, the program will go 

back automatically to the Creation Mode. 

You can select several events at the same time drawing a rectangle grouping several events or selecting 

them one by one with the key CTRL pressed on. 

Shift your events along the scale time, dragging one of the selected events. 

Careful: You can move your events along the time axis but not along the y-axis. 

 

If you made a mistake, you can cancel the last operation pressing the keys CTRL + Z. 

 

Stretch the box with your mouse directly 
Place your mouse at the right side of the box until your cursor become a triangle and change the duration 

with your mouse stretching the box directly. 

 

 
Confirmation message while shifting an event 
 

In order to avoid planning mistakes while shifting a booking on the planning board, a new option was 

added. 

From the menu Tools -> Options -> User, you now have the option “Drag and drop confirmation”. 

 

Then, while moving an event via a Drag and drop with your mouse, you will have this message: 

“Are you sure you want to shift this event”? 
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Forbid events modification 
 
Lock your events 

You can lock some events in order no one to modify them without your agreement. First of all, to have 

access to this option, you must enter the schedule with user’s rights.  

 
Put your mouse on the schedule and click right on your mouse. Select "Lock". You can visualize the locking 

by an icon padlock. 

 

 

Then, double clicking on the locked event, you will see the name of the user who locked the event. Here, 

Paul 
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You can visualize the locking by an icon padlock. 

 

Only the person responsible for the locking or the administrator will be authorized to unlock the event 

selecting “unlock” with a right click. 

Forbid creation and modification of events prior to the present day 

You first have to activate the option going on -> tools -> options-> event and ticking on the option. Past 

events to the current date or to the date selected will not be allowed to be modified.  
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You will then have this message: 
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Split an event into 2 events on different durations 

Select an event on the planning board. 

Then, right click and select “Split”. Your event will be split into 2 events. 

 

 
 
Burst an event into several 1-day duration events 
When you have an event of a duration in days, you can split it with a right click and have several events of 

one-day duration. 

 

Example: this 5 days duration event was divided into 5 events of 1 day. 

 
You can use this option to put some different comment for each day or to assign the event to a different 

resource each day. 

 

Undo function 
 

The UNDO function (CTRL + Z or Menu Edit -> Cancel) is working after doing the following actions: 

 

When you create an event or unavailability 
-> The events created will be removed. 

 

When you shift an event or unavailability 
 -> Events shifted will go back to their original place. 

 

When you split or divide an event or unavailability 
-> The action will be canceled 

 

When you copy and paste an event or unavailability 
-> The action will be canceled 

 

 

Delete events or unavailabilities 
 

Delete one event/unavailability 
 

Select an event and right click and then “Delete”. 

Or you can press the key “delete” on your keyboard. 
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Delete several events/unavailabilities 
 

To delete several events, go on a selection mode and select your events. 

Then, right click and select “delete” or press the key “delete”. 

 

You will have this confirmation message. 

 

 

 

 

 

 

 

 

 

Event duration 

 
Assignment of a duration to the event in hours or days 
 

When you affect a duration to an event, PlanningPME will calculate cleverly the ending date taking into 

account your resources slots: slots and non-working days. You can also indicate a break.  

 

How to use this feature? 

Create an event on your schedule. In the dates, press the double arrow to display the duration option. 
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Careful! An event with a duration can only be assigned to one resource. 

  

 NB : Ticking on "All day" you can enter a length in days. 

Ticking off "All day" you can enter a length in hours. 
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Slots button within the event window 
 

You can register up to 4 slots button within the event window in order to save time: 

 
 

When pressing one of the button, the hours defined for this slot will be automatically assigned. 

To define the slots buttons, go to the menu « Tools » -> « Options » -> "Timetable" 
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You can create up to 4 slots ticking on the boxes « Slots » and giving them a name. 

 

Example:  

- Slot 1: Morning; 9h – 12h30 

- Slot 2: Afternoon: 13h30 – 18h00 

 

 

Tip: You can have the colours of the events displayed in function of the colour given for each slot 

selecting “Timetables” from the menu Tools -> Options -> View. 
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This option is useful while managing up to 4 different rotating shifts. 

 

   

Define a break while creating an event 
 

To activate this option, go to the menu Tools -> Options -> Event -> View and select the box 

“Display a break time”.  

 
You can indicate a break in hours. This time will be taken into account on the hours calculation. 

Careful: Events with a duration in days can have a break in hours assigned! It will not be counted. 
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Events options 
 

PlanningPME is a software entirely customizable. It has initially a simple aspect and can become more 

furnished depending on the options activated from the menu  

Tools -> Options -> Event 

 

We will describe on this document all the options you can activate from this window: 

 

 
 

Number of resources by default 

 
 

Choose if you prefer one or several resources for each event by default. 

If you choose « Several », the tab « resources » will appear by default in the « Event » window. 
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You can, of course, decide to assign an event to only one person even if you chose the option « Several » 

and vice versa. 

By default, we advise you to let this option to “Only one”. 

 

Display a percentage of assignment 
Ticking on this option, a scrolling menu will appear on the event window: 
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What is useful for? 

While assigning an event, if you do not want to decide which moment of the day your resource will do this 

event, you can assign a percentage for this event!  

 

Example: You would like to assign a half day appointment (4h) to your resource without deciding the real 

hours: 

On the schedule, the event will appear on the entire day. But, the real time counted is 50% of the day: 

4h. 
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Display a button « Availability » 

Activating this option, a new icon appears on the event window.  

You can find available resources for this event directly from here: 

 
 

Event reminder using a date 
Selecting this option, you can now use a date as a reminder. 

Then, when creating an event, we can specify a date and time for the reminder. 

 

 
 

Display parameters tab in the event 
  Intervention place and event division 
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When you create an event which takes place to the client’s address, tick on the first box. If you tick off this box and click on 

the button « apply », a new tab « Place » will appear. You can then indicate the place of your appointment. 

 

 
 

 

From this tab « Parameters », you can also decide to split the event ticking on the box « The event is 

divided » then « Apply ». The Tab « Division » appears on your event window. 

Click on “Add” to enter the beginning and ending dates of your divisions. 

 

 
 

NB: You can also split your event via the icon " N Split" symbolized by this icon:  at the top left side 

of your screen. A cursor then appears and you can split your event on the schedule selecting the event and 

cutting it with your mouse. 
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Display invoicing tab in the event 
 Tab "Billing" 

When you create an event, a tab « Billing » will appear on the event window: 

 

 

If you select the type of billing "Unit", the amount will be automatically calculated in function 

of the event duration.  

If you select the type of billing "Package", you can enter directly the total amount. 

You can then know the total amount by resource or by client with the statistics For more 

information, please see chapter on the statistics. 

 

Assign only one event at the same time to a resource  
If you do not select this option, you will be able to allocate several events to a resource at the same time 

period: 

 
NB: If ever you select this option, you will also be able to create several events (if you have the 

permissions) but you will have this warning message each time asking you if you want to force the 

assignment or not: 
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Do not add new labels 
If you select this option, all the new labels that you type while creating an event on the planning board 

will not be added on the list of your events in the menu Data -> Events. 

 

 

 

 
 

Visualise rapidly events with comments 
You can know rapidly wich events have a comment thanks to the red triangle on the right top corner of 

the box. 
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Navigate easily, Change the views and Filter 
 

 

Navigation 
 

Change the time scale and dates 
 

Time period displayed 

 
 

You can choose the number of days you want to display on your screen from a daily view to several years 

view. Selecting “More days” you can choose the exact number of days you want to display on your screen. 

 

Zoom in/out 

If you put your mouse on the dates bar directly, you can switch from a visualization to another clicking 

right on your mouse (-) or clicking left (+). 
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Date choice 

 
 

Choose the day you want your schedule to start from. 

Clicking on the month or the year, go directly to the month or the year wanted. 

 

Go from one week to another via shortcuts keys 

 

Pressing the button (+) and (-) of your lapboard, you can go from a week to another directly.  Those 

shortcuts are the equivalent of a horizontal scrolling bar. 

 

Change the date from the arrows 

 
 

You can go from one week to the other from those arrows. 

 

 

Change the views 
 

Change the view: Resource, Task, Client, Project, Agenda, List 

- Change the time scale and dates 

- Filter events on the planning board from different criteria 

- Display items In Use/Available on a defined view  

- Create customized filters  

 

 
 

 

Views available 

You have many views available: Event, Client, Project, Map, Agenda, List views. 

 Resource View 
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 Event View 

 Client View 

 Project View 

 Agenda View 

 List View 

 

You can make your planning from all those different views. 

 

Ways to change the view 

Different ways to change the view: 

From the drop down filter: 

 
 

From the menu View -> View 

 
 

From the keys shortcuts 

Resource view: CTRL + 1 

Task view: CTRL + 2 

Client view: CTRL + 3 

Project view: CTRL + 4 

Agenda view: CTRL + 6 

List view: CTRL + 7 

 

Agenda View 
 

In addition to the already existing views (resources, tasks, clients, projects, map), Target Skills now has 

developed the “Agenda View”.  
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Display the agenda View 
 

From the drop-down list 

You just need to select it from the drop-down list or the shortcut CTRL + 6. 

 

From the resource view 

Right click on one of the resource and select “Agenda” 

 
Then, the agenda of the resource selected will be displayed: 
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Types of view 
 

On the Agenda View, you have the choice between three types of view: daily, weekly and monthly. 

 

Daily View 

 
You can make a selection of the resources you want to display with the “resources” filter. 

 

Weekly view 
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Monthly view 

 

 
Settings of the view 
 

From the menu Tools -> Options -> Display you can select different parameters: 

 
 

Column width  

Select the size of the resource column: 

 

 

Time Scale 

Select the precision of the display: 
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See minutes on the time scale 

Select whether you want to see the minutes displayed or not. 

 

 

 List View 
 

In addition to the already existing views (resources, tasks, clients, projects), Target Skills now has 

developed the “List View”.  
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Columns available 
 

This list contains columns that you can customize in order to classify, display or not, filter.  

Here is the list of fields available: 

 

 
 
Display Additional fields in the List View 
  

You can also select extra fields on the list view. You need to select the fields you want to add on the list  

first from  the menu View -> Description -> List and indicator 

 

 

Selection, Ordering and grouping of the columns 
 

Columns selection 

You can hide columns that you do not want to display clicking right on the top of the column and then 

select « Delete the column » or you can tick them on or off from the menu « Column ». 

      

 

Ascending or descending order 

Click on the top of the column directly to make the order or right click and select « Ascending order » 

or« descending order »: 

     

 

Columns ordering 

 

Select the column and with your mouse, shift it. 

 

 

Filters 
 

You can also display the events list in function of a filter. To do so, select the column and shift it to the 

box as shown below :  
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You can also right click at the top of the column and select « Grouped by field » 

 

You will then have the events filtered this way: 

 
 

Consult, modify and delete events 
 

Double click on the event or right click and select « Open » : 

You can then modify this appointment. 

You can also delete one or several events with a right click and then « Delete ». 

 

Consult, modify and delete events 
 

Double click on the event or right click and select « Open ». 

 

Copy events or Export to Excel 
After making your selection, you can copy your events or export them directly to Excel with a right click. 

 

 

Filters 

 
Drop Down filters 
 

Filter the resources by department 

Once your departments created from the menu Data -> Department, you can then filter the planning to 

display resources of one specific department. 

 
 

To display several departments, you can use this second filter : 
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NB: you can add some permissions in order to give restrictions on the access to the different departments. 

See chapter on the user rights. 

 

Filter the resources by name 

 
 

We now have a new filter in order to filter more precisely. 

This filter is adapted to the department selected: only resources from the department selected will be 

listed. 

 

 

Filter by category 

Only events of the category selected will be displayed on the planning board on all the different views. 

 

 

Filter by skill 

You can extract resources having specific skills from the schedule. This filter is working only on the 

“resource” view. 

 

Filter by task label 

Only tasks with this label will be displayed on the planning board. 

 

Filter by unavailability 

Only unavailabilities with this label will be displayed on the planning board. 

 

 

Filter by client 

You can display all the events of one or more clients on your screen. 
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Filter by project 

You can display events assigned to a project as previously for clients or events. 

Function In Use / Available 
 

You can display objects in use (CTRL + U) or Available (CTRL + A) on the planning board. 

  

 
 

Filters ergonomy improved: Option to filter the lines 
 

Option to activate from the menu Tools -> Options -> User -> Filter the line 

  

When using the filters in PlanningPME, once you make your selection, not only events will be filtered but 

also the lines. 

 

So, depending on the way you are working, you can adapt the filters behavior to optimize your planning. 

Customise your filters 

 
 

Creation of personal filters combination 
 

You can create a filters combination in order to save time. 

 

On the planning board, make your selection. 

Then, right click on the top bar here and select “Save as”. Give a name to your filters combination. 

 

 
 

So, selecting the views you just saved, you can filter the planning with your own choices. 

In just some clicks, combine different filters easily. 

NB: Each user has access to his own filters and do not see the filters of the other users. 

 

 

Filters on additional fields 
 

Read next Chapter on the creation of specific data to know more. 
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Customise your schedule with your own specific data, Menu 

Data -> Customised fields 
 

The creation of additional fields allows the customization of PlanningPME adding data specific to your 

activity. You can add new specific data on the following windows: 

- Task  

- Client (Possibility to associate a list of equipments) 

- Human resource 

- Material resource 

 

Illustration of this concept: below you have a newt tab created with some additional customized data. 

 

 
 

Aim of the additional fields’ creation: Customize the schedule, display those fields on the schedule, in 

your reports and have statistics. The fields you are going to create can be of several types. 
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Overview of the different types of fields available 

 

  
 

 

Text 
You can type information on one line: 

 
 

Comment 
You will then have a box that you can fill in. 
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Choice 

 
You will then have a drop-down list. 

 

 
 

For this type, you must insert values (Start a new line between each value) in order to have a scrolling 

menu in the tab we are creating. 

 

Date 
You will then have a date that you can select as the birth date of your human resources for example. 
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Hour 
You can specify a time: 

 

Number 
You can type a full number: 

 
 

Decimal Number 
 

You can type a decimal number: 

 
 

Yes/No 
You can then tick on the field: 

 
 

Separator 
It allows you to separate and order your additional fields with a line break. 

 

 

Link to file 
For this type, you have the possibility to create a hyperlink to open a file from the software directly. 

 

 

 
NEW!!! File 
This additional field is available only on SQL Server and MySQL. 

 

The file will be uploaded directly within the database of PlanningPME and anyone will be able to open the 

file wherever he is. 

Select the file from the points and then, open it with the arrow. 

 
 

Geolocation 
This additional field is linked to the mobile version of PlanningPME. Indeed, it will be possible to geolocate 

your employee when he performs a job. The data on his location will then be displayed here once your 

employee check in or out. 
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Type Signature 
This additional is also linked to the mobile version of PlanningPME. Indeed, you can have a signature of 

your client from the mobile version and you will see it here as an attachment. 

Create additional fields     

From PlanningPME, go to the menu "Data" -> "Additional fields »:  

This warning message appear. Press “OK” and begin the set up. 

 

 
 

 

Select in which window to have your new fields 
You can choose in which window you want to add some information: on the event, resource, client 

projects, client equipment, Human resource and/or Material resource window. 

 

  
 

NB : Do not use any punctuation sign (accent, points...) 
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Enter the Tab Title 

 
If you want to add a new tab, type the name of your new tab first and you will see it here: 

 
 

 
Create your new fields within this tab 
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Settings available when you create a new field 
 

Column, Length, Width, Height 
You can specify those information while creating additional field: 

 

 

 

 
Length: This one is a more technical field: this is the length of the path within the database. Do not 

change it unless you are familiar with this data. 

 

Column 1 Column 2 

Height 

Width 
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Creation on the main window: dimensions X, Y to specify 
You can create additional fields on the main window of the event, client and resources. For that you will 

need to precise the location of your new field on the screen specifying the dimension 

         
  

Mandatory field 
-> Mandatory standard fields 

It is now possible to put some standard fields as the event label or the project name as mandatory. 

 
 

X 

Y 
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Then, while creating a new event on the planning, if one of the mandatory field is not filled in, you will 

have a message asking you to fill this field otherwise the event will not be created. 

 
As you can see here, the client must be filled in. 

 

-> Mandatory additional fields 

When creating a new field, you can select the option “Mandatory”: 

 
 

Then, on the planning, if you do not fill this information, you will have this message: 

 

 
 

So, you can force the users to fill some specific data. 

 

Visible on the mobile version 
  

You can select which additional fields you want your employees connecting via the mobile version to see 

or not on the planning board. 

 

 

Filter for fields of the type Choice 
This feature will be described in details in the chapter Filter on the extra fields. 
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Zoom on clients equipments    

Client Equipment: This word "Equipment" can be all kind of objects, equipments that you wish to link to 

your client: machines, contacts, contracts, files, projects... 

 

What is it used for? 
For each client, you will be able to create a list of the different acquisitions or "equipment" in 

details. 

Moreover, for each event assigned to a resource on the schedule, you can precise on which 

"equipment" you are working. 

 

So, on the client card, you will have the new tab you created with all the list of his equipments: 

 
 

And when creating a new job, you will be able to select a client and then the equipment you are working 

on: 
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How to create those "Equipments"? 
From PlanningPME, go to the menu “Data” -> “Additional fields” -> Client equipment – Tab 

Create all the data you would like to have on each equipment: 

 

 
 

Then, go to the client card and open the new tab created: 
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To add new equipment, click on “Add” and fill in the information: 

 
 

Select an equipment while creating a new event 
Once your client selected, you can then select the equipment on the drop down list. 
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Select the fields to display on the event window 
Select the box “Information” when you create your new field: 

 
 

And you will see it here on the drop down menu of the event window: 

 
 

 

Select the fields to display on the planning board 
From the menu View -> Description -> Event / Tooltip, you can display information on the equipments if 

you want. 
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Quick view of the extra fields 
 

For a quicker sight on your additional data, it is now possible to display the content of the extra fields on 

the schedule. This works for the Resources, the Clients and the Projects. 

This is a way to have access to the information entered in your extra fields, as well as a new way to filter 

your resources, since the content is taken into account by the filter. 

 

Visualisation on a new column 
 

On the planning, you can right-click on the space above the resources to have the menu “Column” appear. 

Select the extra field you would like to see on the screen and it will be displayed as shown below: 

 
 

 



 

Tutorial PlanningPME Desktop version  - 111 - 

 

This function is working for the resource, client and project view. So, you can display your specific data 

easily! 

 

 

Display the additional fields on the box 
 

From the menu View -> Description -> Event / Tooltip, you can display the extra fields created. 
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Filter on extra fields 
 

You have different kind of filters on extra fields available. 

 

Create customised filters from fields of the type “Choice” 
While creating additional fields of the type “choice”, if you select the option “Filter”, you can show them 

on the planning board to filter the planning with those specific data. 

 

Activate the filter 

Activate the option from here: 

 
 

AND add it on the View list here to activate (MANDATORY STEP) 

 
 

 

Visualisation of the filter 

You will see the filter on the screen here: 
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You can then filter the planning board. Filters are working the same ways as the other filters.  

 

Filter the planning based on an extra field 
 

Once your additional column displayed, you can even filter rapidly the schedule as shown below: 

 

 

 

 

Import your data 

 

You may have already a database with all the information on additional fields you created. 

For example a list of your resources with information specific to each resource, a list of clients and 

equipments etc... 

 

To save time, we can develop some scripts to import your data on PlanningPME. The cost will depend on 

the format of your files to import. Do not hesitate to contact Target Skills. 
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Customise your schedule with your own dimensions, Menu Data 

-> Additional dimensions 
 

Introduction 

 

Together we can go beyond the limits of the planning with PlanningPME integrating all your data: 

 Ask for an audit of your requirements and we’ll configure together your planning 

 Benefit from our experience with more than 3500 customers 

 

1) Managing project steps 

Directly insert the main steps of your projects through attached files. 

 
 

2) Managing equipment 

Manage the equipment and assign it to employees 

 
 

3) Managing training attendees  

Input attendees to your training without considering them as resources. 
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Practical case: project steps 

 

Would you like to plan main steps for your projects by adding attached files? 

PlanningPME not only allows you to manage projects but also to create a PROJECTSTEP dimension in which 

you can input your projects steps. 

Go to the Data-Menu > New Dimension and add a new PROJECTSTEP dimension stating the project as a 

parent. PlanningPME will create this new table in the database as well as the associated fields. 

 

 
 

 

You can now add fields to the PROJECTSTEP dimension: 
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You can also input steps for your projects: 
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Practical case: assigning equipment to resources 
 

Each firm own equipment like computers, mobiles, pads, cars… These are aimed to employees but don’t 

need to be visible in the planning.  

PlanningPME allows you to create an EQUIPMENT dimension in which you can input the equipment list. 

Go to the Data-Menu > New Dimensions and add a new EQUIPMENT dimension stating no parent. 

PlanningPME will create this new table in the database as well as the associated fields. 

 

 
 

You can now add fields to the EQUIPMENT dimension: 
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You can also input equipment in the Data-Menu > Dimensions > Equipment: 

 

 
 

Now that you have input the equipment, you need to allocate equipment to your resources specifying an 

assignment date; you have to specify that the EQUIPMENT dimension is linked to resources. To do so, go 

to the Data-Menu > New Dimensions, right-click on EQUIPMENT and select Relation to choose connection. 

You should add a DATE field and activate filter to ease your selection. Activate the Check the unicity 

check box so that PlanningPME can only allocate equipment to one and only one resource. 
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You can now allocate equipment in the resource window: 
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Practical case: training management 

 

Would you like to plan trainings for your customers and integrate attendees? 

 

PlanningPME not only allows you to import or input customers but also to create a new ATTENDEE 

dimension allowing you to input the name of attendees to a training for each customer you may have.  

To do so, go to the Data-Menu > New Dimension and add a new ATTENDEE dimension stating the customer 

/ client as a parent. PlanningPME will create this new table in the database as well as the associated 

fields.  

 

 
 

 

You can now add first name and name to the ATTENDEE dimension. 
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You can also input attendees for each customer in Data-Menu > Dimensions > Attendee. 
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You can also find the attendees in the customer window.  
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Now that you have entered the attendees, you would like to plan a training with a series of attendees: you 

need to specify that the ATTENDEE dimension is linked to the event (your training). For this, go to the 

Data-Menu > New Dimensions and right-click on the Attendee dimension. Select Relation to choose the 

sub-connections and options you’d like to have. 
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You can now organize a training and select attendees to this training. 

 
 

 

Select your preferences 
 

Colours on the planning board 

 
From the menu Tools -> Options -> Display, you can select color on your planning board. 

 
Select the colour displayed for the box 
 

 

 
 

On the schedule, each event is represented by a colored rectangle. 

This color can be displayed depending on different types of fields: 

-    Task label 

- Category of the event 

- Client 

- Slots  

- Project 

So, in order to recognize easily all events associated to a client, you can choose to display events 

depending on the client color. 

 

Select the colour by default 
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You can select colours by default for all those different items: 

 

 
Play with the events gradient colours 
Gradient colours: 

                                           
 

From the menu Tools -> Option -> User, you can activate options in order to play with gradient colours and 

corners. 
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Select fields displayed for the box, the tooltip and the list view  
 

 
 

From the menu View -> Description, you can select the information you want to see on the following 

destinations: 

- Event: Boxes that represent events 

- Tooltip 

- List and indicator 

 

The window below appears. 

 
 

Select the fields with a double click on the field or selecting the field and then “Add” button. 

Start a new line: This field allows you to have your description display on several lines. 

 

 

Fields within the event box 
 

Fields displayed on the box that represent an event: 
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Note that this description is adapted to each view: 

On the client view, the name of the client will not appear. 

On the Project view, the name of the project will not appear… 

 

Tooltip 
 

Fields on the yellow tooltip that appear when you put your mouse on an event: 

 
 

List and indicators 
 

You can add your additional fields on those views. 
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Timetable preferences 
 

From the menu Tools -> Options -> Timetable, you can select different customised settings for week and 

hours preferences. 

 
 

Working week 
 

Select the days you usually work on from the wizard. Then, the default profile of your resources will take 

into account those settings. 

For example, if you do not work on Saturday and Sunday, the default profile for each resource will be the 

same.  

 

First day of the week 
 

Select the first day of week. Then, on the calendar, the first column will be the first day selected: 

 
 

And on the planning board, the week will be delimited as shown below: 
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Timetables 

 
 

You can select your time preferences here. They will be displayed then while selecting the views morning, 

afternoon, day. 

 
 

Beginning and End time 

While displaying the daily view, the time selected will be displayed. 

 

Morning 

While displaying the morning view, the time selected will be displayed. 

 

Afternoon 

While displaying the afternoon view, the time selected will be displayed. 

 

Beginning of night hours 

This setting will be used on Excel Pivot table to make reports on night hours. 
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Preferences of the planning from the Language menu 
 

From the menu Tools -> Language, you can select different customised settings. 

 
 

Language 
 

Select your language. You can define the language per computer. 

The software PlanningPME is available in: french, english, german, spanish, dutch, italian, swedish 

 

Terms 
 

You can rename different fields in order to customise the planning to your activity. 
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A client can be renamed a customer. A Task can be a mission…. 

The changes made will be transfered in the menu "Data" and in the filters and different windows name. 

You can rename different fields in order to customise the planning to your activity. 

 
Other 
 

Number of decimal points 

It is possible to choose the number of decimal points. 

 
 

Decimal Separator 

In function of the countries, the decimal separator can be: 

A comma or a point. 

From this menu, you can customize it: 

 
 

NB: you will need to set up this option correctly in order to use Excel Pivot Table. 

 

Monetary symbol 

You can choose between all the currencies listed.  

 

Hours and dates format 

You can select the format of hours and dates. 
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Other preferences 
 

You can customise the planning to your activity selecting the colours, renaming some terms etc… 

 

Preferences of the planning from the Options menu 
 

From the menu Tools -> options -> View, you can select different display options. 

 
 

Font and size 

Choose the font: type and size; This font will be applied on all the schedule. 

 

Brand 

Select your logo. Optimal resolution: 45*45 (pixels) and bitmap format. 

 

Maximum height of one line 

You can raise the height of your lines for a better visibility. 

 

Number of visible lines 

You can select the number of lines displayed on your screen. 

 

Display the event on all the day whatever its duration 

If you want to see more information, you can select the option: Events not proportional to hours. 

All the events on your planning board will appear on the whole day whatever the real duration as in the 

example below. 
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Activate refresh button 

 
 

 

Select the first week of the year and display week numbers 
 

Week Number 1 is either the week including the 1st of January or the week after (First week with 4 days). 

So, in order to suit all markets and countries, you can now select this first week from the menu Tools -> 

Options -> User. 
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First week of the year: 

Week including the 1st of January or not. 

 

Display the week number 

 
 

Why should you hide the week number?  

It appears that depending on your Windows version, the week number is not the same as the one you 

selected as “First week of the year”. This is not something that can be changed by Target Skills as there is 

no solution yet on the market to solve this problem. That is why you have the option to hide the week 

number if ever it does not correspond to your selection of “First week of the year”. 
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Non working days keep visible 
 

It is now possible to keep visible non working days. 

For example, you have an event on several days as shown below: 

 
Now, from the menu Tools -> Options -> User, you can select the option “Events not visible on days not 

worked”. 

You will then see the days not worked: 

 
NB: If you plan events on days not worked, they will not be displayed if you select this option! 
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Search, Analyse and Print your data 
 

Search your data and search available resources 
 

Several types of search are available in PlanningPME. 

 

- Function “Search” (CTRL + F) 

It is a search of events by keywords. 

 

- Search for availability: You can search for the availability of your resources in order to assign them an 

event of certain duration, at a certain date depending on their skills. 

 

Function “Search” (CTRL + F) 
 

Find out easily your events thanks to keywords on a crowded schedule. 

From PlanningPME, go to the menu "Edit" -> "Search" or press simultaneously the touch "CTRL" and "F" 

or click on this icon :   

 
The window below appears 

 

Find an event 

To find out your events easily, here is the way to proceed: 

1 – Enter the keyword 

2 – Choose the field where your keyword is present: event, comments, client or client N°… 

3 – Click on the button « Find » 
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Results are then displayed on the results window. 

For a best result, you can use the symbol '*'. 

 

The symbol * means that there is some text before or after the keyword. 

4 types of search are available:  

- Exact search  

Example of search: Training 

Example of results: Training 

 

- Keyword at the end of the sentence 

Example of search: *client 

Example of results: Maintenance client 

 

- Keyword at the beginning of the sentence 

Example of search: Intervention* 

Example of results: Intervention from 1pm. 

 

- Full text search 

Example of search: *advanced* 

Example of results: Word advanced training 

 

Open or Delete an event 

You can open or delete an event selecting one of the results and then, right click, “Open” or "Delete". 

 

Search on additional fields 

Now, you can make a search on the additional fields you created. 

 

Search for resources, clients and projects  
 

From the menu Data 

 
 

While typing the first letters of the name of a resource, only resources beginning by those letters appear. 

This new function also works on clients and projects. 

 

From the planning board directly 

You now have a fast “typing” zone at the left top side of the planning board: 
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So, when you type the label, the lines are filtered and the software is doing a full search. 

This fast search is working on all the views of the planning board like the client view or the project view. 

 

From the event window 

  
 

When creating a new event, you can search by the project name or the client name pressing the “glass” 

icon. 

 

Search for available resources 
 

This function allows you to find easily the resources available for a specific event without having to check 

on your crowded screen. 

 

From PlanningPME, go to the menu "Action" -> "Availability" or click on this icon:  

The window below appears. 
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Settings to find your available resources 

 

Choose those different parameters: 

 

-> From – Up to 

Select the period you want to make your search on 

 

-> Task 

Select the task to perform on the list. 
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-> Skills 

If you select a task with skills predefined, only skilled resources will be displayed. 

If you do not select any task label, you will be allowed to add a specific skill that your resource must have 

to perform the job. 

 

NB: To search for skilled resources, you must not select any task label. 

 

-> Length 

 Duration of the task in hour or in days 

 

-> Resource 

Filter by department and even more precisely, by resource if needed. 

 

You can also filter by resource under contract only. 

 

-> Find button 

Click on the button "Find": all resources with the skills mentioned and their first availability date will be 

displayed on the screen, at the right side of the window. 

 

 

Create your event 

Select the resource available that will do the job, right click and select “New event”. 

 
 

Your event will then open. 

 

 

Option “Go to” 

This option shows you on the screen the period of the result before you decide to create the new event. 
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Indicators: Planning data displayed on real time 
 

 
What is an indicator? 
 

The indicators show real-time calculated data based on the information contained within the schedule. 

They are displayed as lines, columns over a daily, weekly or monthly view. 

This way you can see for instance, the number of a certain type of events, the total duration of another 

one over a week or the number of not worked hours for one or several resources. 

 

How to create an indicator? 
 

When doing a right-click on the resources column the following menu appears: 

 You can select Add, and the sub menu containing ‘Resource’ and ‘Indicators’ appears. 

 

 

The Indicator menu 
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Count 

  
In the first section of the menu, you need to specify what data the indicator is going to be showing. Here 

is the explanation of the different elements from this menu: 

 

 1: Data.  

  This is the type of the indicator; you have the choice between those items: 

    

Type Description How to use it 

Additional Field You have the possibility to process data 

entered in the additional fields of the 

events, clients, or resources. 

You have to create extra fields 

first. Then, Go to menu View -> 

Description -> List and Indicator 

and add the fields you will need 

to be processed by the indicator. 

Duration of the events With this option, the indicator will 

display the duration of the selected 

element. Number of hours of any given 

task, duration of an unavailability, etc… 

Add a criterion in the field [4], 

specifying the Label of the event, 

and validate 

Effective Capacity This represents the ‘workable time’ for 

a resource, based upon his/her time 

slots and the unavailabilities. 

Add a criterion in the field [4] 

and specify the label of the 

resource. 

Not Worked time The global not worked time of the 

resource.  

Add a criterion and specify the 

label of the resource. 

Number of events The indicator will display how many 

events there is, per day. 

Add a criterion and specify the 

label of the event / task. 

Theoretic capacity Work time for a resource based on the 

total of hours from his/her time slots. 

Add a criterion and specify the 

label of the resource. 

 

 2: Target 

This value represents the maximum value to-be-reached for the indicator. It is displayed behind a ‘/’ 

symbol. 

Example: an indicator showing the Effective Capacity over the Theoretic capacity: 

Select Effective Capacity, and click on [Target], Select Theoretic Capacity. Validate, Select a Label for 

your indicator, set a colour, and validate. Your indicator now shows the total of workable hours out of the 

total work time of your resources. 

 

 3: Field 

If you have added an extra field to the List and Indicator option, you will be able to select this field in the 

drop down menu, and have the indicator display its value. Only ‘number’-format fields are processed. 

 

 

 4: Criteria 

It is possible to add conditions related to the information you want to be displayed. You might want to 

have the amount of time spent in a certain type of task displayed in the indicator, but you can refine it so 

that it is limited to one or several resources, clients, departments, categories etc… 

Example: 

Select duration of the events, and add a [Target]: 

- Duration of the events 
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- Criterion 1: Task . Label . = . “Meeting” (for instance) 

Close the target Window 

Select the criteria for our indicator: 

 - Criterion 1: Resource . Label . = . “Denis EMART” 

 - Criterion 2: Task . Label . = . “Meeting” 

Select the ‘Hour’ Format. 

Add a name, a colour and the location of your indicator, validate, and you should have on your planning 

the hours spent in morning meetings for your Manager over all the hours spent in morning meetings for 

everyone: 

 
  

5: Format 

You can select in which units you want the indicator to convert the data. 

 Day: The duration will be displayed in days. 

 Difference (Days): A calculation will be made between the duration of the [Target] and the 

Duration of the [Criterion] of the indicator. 

 Difference (Hours): Same operation but measured in hours. 

 

 Example: 

The [Target] is the hours of ‘Support’ of one resource.  

 - Duration of the events 

 - Criterion 1: Ressource . Label . = . “Fidel Sporcic” 

 - Criterion 2: Task . Label . = . “Support” 

The [Criterion] of the indicator is the global amount of Support hours. 

- Duration of the events 

- Criterion 1: Task . Label . = . “Support” 

 

Select ‘Difference (Hours)’ format, add name, colour, position, and validate. 

Your indicator will display on the screen. 

 

 

 Hour: the time will be counted in hours 

 Percentage: If you need to show a ratio 

 Value: used for counting number of occurrences, extra fields values, any number that 

is not a duration nor a ratio. 
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View 
 
6 - Label: You can set a name for the indicator, describing what this indicator stands for. 

7 - Colors: This is the background colour of the indicator, as well as the color of its line on the 

planning. 

8 – Threshold: If the indicator exceeds the threshold value, then the corresponding color will be 

displayed on the schedule. 

9 – Height: The height of lines can be modified in this menu; you can also modify it directly by 

click-holding and moving the top or bottom line of the indicator on the planning. 

10 – Position: The indicator will be placed either above or below all the resources. The position is 

dynamic and will automatically remain atop or at the bottom of the schedule. 

11 – View: You can have the indicator displayed only on certain views; you can choose the view in 

this drop down list. 

12 – All Services: The indicator will be shown on every service by default. You can specify on which 

service view it will appear if you need to restrain the access to the indicator. 

13 – Private: the indicator will only be displayed for the current user, other users will not have 

access to this indicator. Is opposed to the ‘All services’ option. 

14 – Comments: Comment section for the indicator. The comment is displayed as a tooltip when 

you point at the indicator on the schedule. 

 
 
Using the indicators 

 

Limiting the number of –a task- on the schedule 

 

The management department cannot have more than 4 trainings a day with the clients. 

We will define an indicator showing us when there are more events of this type than there must be 

planned. 

 

1) Select number of events. Add a criterion Task . Label . = . Training, validate. Select ‘Value’ as 

format. 

 

2) Add a name and a colour, click on threshold. Add a threshold which value is 4 with a red colour. 
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The Indicator turns red. 

 

 This method can also be used to monitor how many of a task is done each day, or week. 
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The Not-worked time of a department 

 

The Not-worked time can be assimilated to the time left to a resource or a group of resources. 

We will define an indicator showing the percentage of time remaining to a department. 

 

1) Select ‘Not worked time’, add as criterion : 

- Department . Label . = . ‘Accounts’ 

 

2) Add as format : ‘Percentage’ 

 

You will notice that there is no immediate effect, indeed, we need a reference to build the ratio; we will 

add a [Target] to have the results. 

 

3) Select ‘Theoretic Capacity’, validate 

 

The theoretic capacity is the number of hours that a resource must work as defined in the time slots. The 

program uses this value as a reference. 
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Statistics from the menu Tools -> Statistics 

 

 

Statistics defined on the software: Statistics by day, week or month of the hours worked by resource... 

You can then make some statistics from this window pressing the button “Statistics”: 

 
 

 
Criteria to select 
 

Type  

Choose whether you want to make statistics on your events, unavailabilities or contexts. 

 

Statistics 

Select the data on which you want to make your statistics: resources, events or clients 

 

 

Unit 

Have your statistics displayed on hours, days or number. 

 

 

What is the unit “Number”? 

While selecting this unit, the number of events or resources working on the period selected are counted. 

 

-> Statistics on resources: The number shows the number of events for each resource. 

 

-> Statistics on event: The number shows the number of resources for that event. 

In the example below, we have four resources that had a development on 28: 

 

-> Statistics on client 

The number shows the number of resources working for this client. 
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Dates 

Give the beginning and the ending date for your statistics 

 

Filter 

It is the filter by departments. Make statistics on all your resources or on a particular department. 

 

Column 

 

Choose if you want your statistics to be displayed by day, 

week or month. 

 

 

Buttons description 
 

Button Statistics 

Press the button to have your statistics displayed: 

Button Copy 

 Copy statistics displayed and paste them on a database such as Excel in order to save them. 

 

Button Export 

The statistics will be exported in a HTML format. 

 

Button Print 

Print your statistics 

 
Workload 
 

You can have the workload of resources on the time period selected. 

It is calculated in function of the “slots” of the resource defined on the tab “Slots” in the resource card. 

 

 
 

 

 

Cost 
 

You can have the total cost of your resource that is calculated in function of the cost per hour you 

specified from the resource card. 

 

Billing 
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You can have the total cost of your events billing. The amount is calculated in function of the amount on 

the tab “Billing” of the event window, if activated. 

 
 

Excel Pivot Table 
 

A powerful feature of our planning software PlanningPME is the possibility to make reports via Excel Pivot 

Tables. All the data regarding resources, clients, projects, events, unavailabilities can be exported to 

Excel in order to have precise reports. Pivot Table allows calculating and comparing all kinds of elements 

in just some clicks. 

 

You can make many reports on the data of your schedule.  
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Moreover, once your templates created (reports on resources, clients, days off...), it will be possible to 

update them easily selecting the dates only.  

 

Create a new Excel report 
 

From PlanningPME, go to the menu "Tools" -> "Pivot Table". 

The following window appears: 

  
 

Different steps and options to create your reports: 
New /Existing report 

 Create a new report or start from an existing report 
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Beginning Date and End date 

Enter the beginning and ending dates of the period to analyse 

 

Box Department 

Tick on this box when a resource is part of several departments and you make reports by department. 

 

Data 

All the data you can make reports on 

To analyse 

Which data do you want to analyse? hours, days... 

 

Lines 

Which information must appear on the lines of your spreadsheet? 

 

Columns 

Which information must appear on the columns of your spreadsheet? 

 

Filters 

To have a filter on the Excel report. 

 

Button Advanced 

To select additional fields you would like to have on your Excel reports. 

 

 

Button Excel 

Press this button to generate your report 

 
Save your report as an Excel Workbook 
Once your report created, do not forget to save it as an Excel format. Indeed, otherwise, it will be saved 

as a txt file! 

 
Build templates and Update your Excel reports easily 
 

Do you know that you can save up to 10 templates in PlanningPME?  

Indeed, once your different templates created, you will just need to update them regularly selecting the 

dates in Pivot Table interface of PlanningPME.  

 

Save your templates 

Just save them clicking on the arrow here: 



 

Tutorial PlanningPME Desktop version  - 153 - 

 

 
 

Update your reports 

After having defined the type of reports you wish to have, you can now update your reports regularly 

selecting the dates. Select "Existing report". 

 

 

Then, select the template you wish to use on the drop down list. 

 

 
 

Then, select the Beginning and End dates for your reports and press “Excel”. 

 

Remove a template 

Select your template and click on the “Cross” icon to remove the report from the list. 
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Print Options 
 

From the menu File -> Print, you have the possibility to print different views of the planning: 

 

 
 

 

- Graphic schedule 

- Operational schedule per resource 

- Operational schedule per client 

- Daily schedule 

- Weekly schedule 

- Operational schedule 

- Status of unavailabilities 

- Print an event 

 

We are going to give you an overview of all the different options. 

 

Settings before printing 
 

Fields to print 

To select the fields you would like to print, click on “Settings.” 

Then, you select the data to print from here: 
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Time Period to print 

Note that the time period printed is the one you see on your screen. If you display one week, one week 

will be printed. If you display one month on your screen, one month will be printed. 

 

Resources printed: one department or one resource 

-> If you want to print the planning of one department, filter first the planning by department. 

 

-> If you want to print the planning of one single resource, right click directly on the resource on the 

screen and select Print. 

 
 

Filters 

You can first filter the planning by client or project for example. Then, only information related to the 

planning filtered will be printed. 

 

Title 

You can give a title to the document printed if needed. 

 

Print percentage 

You can reduce the size of the text printed in order to print more information. 

 

 



 

Tutorial PlanningPME Desktop version  - 156 - 

 

Menu File -> Print Configuration 

From the menu File -> Print configuration, you have those parameters available: Printer, Page Size, 

Orientation. 

 

 
 

 

Overview of all the prints available 
 

Graphic schedule 

This is the planning you see on the screen. 
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Operational schedule per resource 

It is the operational schedule per resource on the period that appears on your screen. Fields printed are 

those chosen from the settings.  

 
 

NB: We remind you that to print only one resource, you can right click on the resource name and select 

“Print”. 

 

Operational schedule per client 

It is the operational schedule per client on the period selected on your screen.  

 
If you wish to print the schedule of a single client, select it first on the client drop down menu. 

 

 
Daily and weekly schedule 

The print will look like that with the hours on the left size. 



 

Tutorial PlanningPME Desktop version  - 158 - 

 

 

 

 

Operational schedule 

It is the chronological schedule for all resources on the period that appears on your screen. Here is an 

example: 

 
 

The schedule of all your resources is grouped in one schedule in a chronological order. 

 

NB: If you have a lot of events to print, it is possible to print the schedule on several pages. 

To do so, go to the menu Tools -> Option -> Advanced and select the number of lines per 
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page. A line represents the details of an event. The number of lines per page depends on your 

screen resolution and the quantity of comments.  

 

Status of unavailabilities 

It is a resume of your resources days off and unavailabilities. 

 
 

You know at any time how many days your employees have been off and how many days off 

they still have for one year. 

 

Print an event 
 

Standard print 

You have the possibility to print information on an event from PlanningPME. 

Select an event on the schedule and then, right click and select "Print". 

 
The fields printed by default are the following: Name of the event, Beginning and ending dates and hours, 

Resource Name, Client Name and Address, Project Name, Comments. 

 

Customised event print 

Via a specific development, it is possible to print a customized mission sheet by event! 

You just need to send us your template with the fields you want to display (with additional fields created 

eventually). Contact us for more information. 

The prices depend on your template and fields to synchronize. 
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Notify your employees 
 

Visualisation to HTML pages 
 

Regularly, you can send your schedule on your local network or on the Web under HTML pages in order all 

the employees to visualize the daily, weekly schedule. 

Careful: You cannot make any changes from the Web on the schedule. 

 

Definition 
 

You can generate HYTML pages of the planning for visualisation. 
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Double clicking on one of the events, its details appear: 

 
 

Careful: Only resources that appear on your screen are synchronized. 

 

If you want all your resources (including resources that does not appear on your screen) to be 

synchronized (creation of several HTML pages), we suggest you to choose the solution PlanningPME HTML 

or PlanningPME Web Access. 

 

Set up 
 

From PlanningPME, go to the menu "File" -> "HTML visualisation" 
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Instructions to generate your schedule on HTML pages: 

 

Select the views 

Select the views you want to synchronize. As an example, selecting weekly, the weekly schedule as you 

can see it on your screen from the first day of the week will be sent on HTML pages on the folder chosen. 

 

Directory 

Indicate the folder where you want your HTML pages to be created. To do so, click on the arrow under 

“Directory”. 

 

Size 

Select the width and the height of the pages generated (it can not be superior to your screen resolution) 

 

Generate 

You can synchronize « on start » or « on exit » of PlanningPME or simply clicking on the button 

« Generate ». 
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Send an email 

 

It is possible to send an email to inform the resource and/or the client of a new event. 

 

From PlanningPME, go to the menu « Tools » -> « Options ». Choose the tab "Outlook". The 

following window appears. 

  

 

SMTP Configuration 
 

Server SMTP: Specify the address of your server 

E-mail Address: Specify the email of the sender 

Name: Specify the name of the sender 

Copy: Each time you send an email, a copy will be sent to the address mentioned here. New: You can add 

several persons in copy of each email sent adding a comma “;” between each email address. 

Mobile: Phone operator. Enter the suffix of the email address of the mobile. Depending on your phone 

operator, this option will be available or not. 

Precise if you want to send an email to the resource(s) assigned to the event, to the client or to both of 

them (Resource + client) 

 

Outlook Configuration 
 

If you select Outlook you have more functions while sending an email. You can select the fields 

on the subject of the email, on the body etc… 

 

 

Select the subject of the email sent 

You can select the fields you want to have while sending the email like Client Name + Project name or 

whatever from the button “Subject” 
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Select fields on the email sent 

You can also select the fields you want to have while sending an email from the button “Body”. 

   

Display the message before sending it 

It is possible to display the email and add any information or text you want before sending the email.   

 

Attach the mission sheet 

It is possible to attach a customized mission sheet while sending an email. 

This mission sheet is the one you specified from Tools -> Options -> Mission Sheet. 

 
To have your own customized mission sheet, we invite you to contact Target Skills to discuss your 

requirements and have an estimate. 

 

 

Send an email 
 

Fill in the email address of your resources and clients to have the option activated: envelop icon 
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On the "Event" window, click on the envelop icon to send an instant message to all resources assigned to 

the event, to the client or both depending on the options previously selected. 

 

 
Send an Outlook invitation 
 

From PlanningPME, you now have the possibility to send an Outlook invitation while creating a new event 

just clicking on the icon below: 

 

 
You can activate this option from Tools -> Options > Outlook. 

 
 

 



 

Tutorial PlanningPME Desktop version  - 166 - 

 

Visual alarm 
 

You have the possibility to use a visual alarm which will remind you an event before its beginning: 5 

minutes, 10 minutes, one hour before... or at a precise date and time. 

 
 

Activation of a reminder before the beginning of an event 
 

Tick on the box "Reminder" and choose the time for the reminder. 

 

 

If you enter the planning with user rights, the reminder will be activated on the session of this user only. 

The other users will not see the reminder. 
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Activation of a reminder specifying a date and a time 
 

To activate this kind of reminder, select the option on the menu Tools -> Options -> Event 

Select “Event reminder using a date”. 

 

 Then, while creating an event on the planning board, you now have a calendar: 
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Events notifications 
 

Be informed at a glance of the last changes on your planning via badges or notifications on the toolbars 

 

What is a notification? 
 

A notification informs users of new or modified events and/or unavailabilities that are related to the 

planning activity. 

The notifications can be defined per user and you can have relevant information on events and/or 

unavailabilities changes for one or several resources. 

Notifications can be activated in PlanningPME as red badges on the planning board and / or notifications 

on your bottom toolbars.  

 

Activate notifications 
 

First, activate the option from the menu Tools -> Options -> Event and select "Activate notifications". 

Then, on the menu "View", you will now see the menu "Notifications”. 

  
 

Then, each user will do the settings of his own notifications: when connecting to his session (users rights 

must be activated in the software), he can decide whether he wants to be informed of additions and/or 

modifications of the events allocated to the different resources listed.  
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Visualisation of the notifications on the planning 
 

When a user logs in to the planning board, red buttons indicate which events (events or unavailabilities) 

were created or modified on the scheduler. 

 

Notification of the type "Badges" 

 
The icon with a "+" symbolises a new event. 

 

Notification of the type "Windows notification" 

 
 

List of notifications 

You also have a listing of all your notifications from the menu View -> Notifications: 
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Remove the notifications icons 

If you want to remove the notifications icons, you just need to open the event or the unavailability. You 

can also deselect the option "Activate notifications" from the menu View -> Notifications.  

 

Other notifications 
 

Events notifications when the application runs on the background 

 

On the new version, when PlanningPME is not the main working window opened, instead of opening 

PlanningPME as the first window, you now have some notifications. 

 

-> When a new reminder comes up, you will have this notification on your screen: 
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Administrate your users and your data 
 

Users rights 
 

With a login and a password, each user or users groups will have specific access to the schedule (Modify, 

Delete, Visualize...) 

There are two steps to create users rights: 

- Groups creation with specific rights 

- Users assignment in each group 

 

Vocabulary used 
 

For each field of the software, you will have one or several boxes to select depending on the authorized 

level of access. The different situations are as follows: 

 

1st situation: You have only one box to select 

You give access to this field or not. 

Example:  

Right not accessible:  

Corresponding menu in the software: Data 

The user does not have access to the user rights: fields are greyed out 

 
 

 

2nd situation: 
 

For each data (department, resource...), you can choose the following rights: 

 

Consult: Reading access to the data concerned 

Add: Addition of a new data (new department, new resource...) 

Modify: Modification of the information on a data 

Delete: Right to delete a data 

 

3rd situation: 

 
Visible: The fields entered can be read or not 

Accessible: The different fields can be modified or not 

 

Example: The different possibilities for the field "Label" are: 

 

Visible and Accessible: Full rights  
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Visible but not Accessible  

Not visible and not Accessible  

 

 

Groups creation with specific rights 
 

From PlanningPME, go to the menu "Data" -> "Group". 

 
 

From this menu, you can create groups with specific rights on all functions and data of the schedule. Right 

to create events, to visualize unavailabilities, right to print... 

First, click on the button "Add" to create a new group. 

In the "Group" window, several tabs appear. Let's explain rights for each tab. 

 

Tab "General" 
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In the rights organization, there are 4 different domains: 

- Internal Set up 

- Definition of the structure 

- Current use of the schedule 

- Advanced functions 

- View 

 

We are going to describe those 4 domains hereafter. 
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 Internal set up 

 

The internal set up of the software is an operation which occurs while 

installing the software and then, episodically. 

Those operations are done by the Administrator. It is necessary to be 

trained on the software to modify those parameters which impact 

every users. 

 

You can choose who can or cannot have access to the following 

parameters. 

 

 

Available fields Corresponding fields in the software 

Database File -> New schedule + Location 

Purge File -> Database -> Purge 

Registration of the licences File -> Identification + Registration via Internet or by file 

Rights of users Data -> Group + User 

Category Data -> Event category 

State  

Public holidays Data -> Public holidays 

Additional fields Data -> Additional fields 

Days Off Tools -> Days Off 

Labels and formats Tools -> Labels and formats 

Options Tools -> Options 

Description  View -> Description 

Import File -> Import 

Export File -> Export 

History Data -> Event description 

Notifications View -> Notifications 

Synchronization File -> HTML visualization 

 

 

Definition of the structure 

The definition of the structure is an operation which occurs while installing and setting up the software. 

It is then changed occasionally, while integrating a new resource or a new department or re-structuring 

the society. 

This structure is defined from the menu "Data". 

 

Users rights Access from PlanningPME. 
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Current use of the schedule 

Those functions are currently used on the schedule: a user will be allowed or not to create events, to 

delete them, to update them. 

 
Available fields Corresponding fields in the software 

List of tasks Data -> Task 

List of unavailabilities Data -> Unavailability 

Event Direct modification on the planning board 

Unavailability Direct modification on the planning board 

Context Access to the context feature 

Indicator Access to the indicator feature 

Milestone  

Search - Find Edit -> Search 

Statistics Tools -> Statistics 

Pivot Table Tools -> Pivot Table 
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Copy/Paste 
Edit or right click on an event or on an unavailability -> Copy + 

Paste 

Printing File -> Print + Print preview + Print configuration 

Selection / Creation Mode 
 

Force Context Force the creation even if a resource is already busy 

Force contraints Force the creation even if the contraint is not respected 

Force Skill Force the creation even if the resource does not have the skill 

 

Advanced functions of the schedule 

 
Those functions must be used by trained users! 

Available fields Corresponding fields in the software 

Split 

 
To Split Edit -> To split 

Availability Edit -> Availability 

Event Locking / Unlocking 

 
For each window "Client", "Resource", etc... you can specify rights of access and visibility for each tab and 

most of the fields of each window. 



 

Tutorial PlanningPME Desktop version  - 178 - 
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Tab "Resources" 

 

 
Each resource has a personal card. For each information, users rights can be assigned. 

Access to the tabs: the tabs of the card are accessible or not 

Tab Information: For each fields of this tab, it is possible to give a right to visualize and a right to modify. 

"Human resource" and "Material resource" are tabs with additional fields customizable that can be created 

on the resource card from the menu "Data" -> "Additional fields". 
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Tab "Client" 

 
Each client has a personal card. For each information, users rights can be assigned. 

Access to the tabs: the tabs of the card are accessible or not 

Tab "General”: For each field of this tab, it will be possible to give rights of visualization and accessibility 
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Tab "Options" 

 
You can give access or not to the tabs of the menu "Tools" -> "Options":  
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Tab "Event" 

 
Tab1, Tab2 and Tab3 are tabs with additional fields customizable that can be created from the menu 

"Data" -> "Additional fields". The tabs "Billing", "Parameters" and "Place" appear only if they are activated 

on the menu "Tools" -> "Options". 

Note that some fields as the event label or the project name can be mandatory to fill. 
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Tab "Unavailability" 

 
For each information of the unavailability window, access rights can be assigned. For each field of this 

tab, it will be possible to give rights of visualization and accessibility. 

 

Once all your groups registered with specific rights, you can create the users. 
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Creation of the users 
 

From PlanningPME, go to the menu "Data" -> "Users". You can create a login and a password for each user.  

  
 

 

 

 

Enter a login 

Enter a password 

Confirm the password 

Assign a group to this user 

Mobile Access: to have this user on the mobile 

application 

Select the department(s) this user can visualize. 

Select the department(s) the user will have access 

in writing 

Select the resource that corresponds to the user if 

needed 
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You created a new user with specific rights on the schedule. 

 

 
Tick on the box "Ask the user to enter his password" for users rights to be activated while opening the 

schedule. 

Next time you open PlanningPME, a login and a password will be asked. 

 
Depending on your rights, you will have an access limited to the schedule. 

 

Automatic authentication 

If your user name is the same as your Windows user name, you will not have to enter a password. Your 

rights will be automatically taken into account while opening PlanningPME. 
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Give access to only one resource 

If you assign the user to a resource on the planning board and that you do not select anything departments 

for reading and writing access, then this user will see the planning of this resource only. 

 

 

Select or deselect all departments 

Right click at the top of your drop down list of department to save time checking on or off all boxes. 

 

 
Access rights to clients 
You can limit the planning by clients: Then, when the user opens the planning, he will not see events 

allocated to other clients.  

From the menu Data -> User, you can now limit the list of clients per user.  
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NB: You will first need to create a group with a minimum condition: « Access to all clients » must be 

unchecked. 

 
 

Then, when the user opens the planning, he will not see events allocated to other clients.  

 



 

Tutorial PlanningPME Desktop version  - 188 - 

 

 

Examples of permissions 
You can create those kinds of permission for example: 

-> Rights to visualize the schedule of two departments and to modify the schedule of one department 

-> Rights to create unavailabilities and not events 

-> Right to modify comments of the event but not the other parameters of the event. 

-> Rights to visualize the details on resources. 

 

 

Offline Mode 
 

We now added a new feature that allows you to work off-line with your planning! 

Indeed, if you are not connected with your network (disconnected from your database), you will still be 

able to create and modify events and unavailabilities on your schedule. 

While reconnecting to your network, events and unavailabilities will be synchronised and there will be a 

check for conflicts, if any. 

 

 

Minimum requirements 
 

This feature is working only if you have a SQL-Server database. The off-line mode is not working if you 

have a MS Access database (pp file). 

 

We can migrate your database from MS Access to SQL Server. Contact us to have more information. 

 

When you are disconnected from the database, PlanningPME is creating an offline database. 

 

 
 

 

Resume 
 

Database SQL Server 

Activation Create Groups and users 

When Offline   

You can Create events and unavailabilities 

You can not Create new clients, projects, resources etc... 

 

 

How to activate this feature? 
 

Note that the Admin Group can not have access to the “Offline” mode as this feature is desactivated by 

default. You will then need to create a new group and some users as described below. 
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Menu Data -> Group 

By default, this option is not activated on the users rights. So, you need to give the users permission from 

the menu Data -> Group 

 
 

 

Deselect “Offline unauthorized”. 

 

Timeout: Specify the frequency of the tentative of reconnection to the database when offline 

 

Days before / Days after: Define the period of synchronisation of events 

You can synchronise a maximum period of 90 days before and after current date.  

 

Menu Data -> User 

Then, create a user part of this new group created from the menu Data -> User. 

Do not forget to select the option “ask the user to enter his password”. 
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Connect to the planning with your users rights 

Then, you can open PlanningPME with your login and password: 

 
 

 

When is the offline database created?  
 

The Offline database is created when you close PlanningPME or when you are disconnected from the 

database. 

 

How can I see that I am offline? 
 

You can see that you are offline when you see this icon here: 

 

 
 

You will also get this message as a local database is then created on your computer: 

 

 

What can I create when I am offline? 
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-> You can: 

The user can Add/Modify/Delete events and unavailabilities depending on his users rights. 

 

 

-> You can not: 

The user can not Add/Modify/Delete resources, customers and projects (Settings that are in the menu 

Data basically). 

 

The user can not get an event off a recurrence. 

 

 

How are conflicts handled? 
 

If no users make modifications on the events that you changed, your modifications will be applied directly 

when you are back on the online planning. 

 

If another user change the same events, then this conflicts window will open: 

 

 

 
 

-> You need to solve conflicts first before being able to work again online. 

 

You can open the events via a double click to check details. Then, you need to select which modification 

for this particular event should be applied. 

 

On the print screen above, you have two conflicts: one for the event, Key 6 and another one for the 

event, key 19. 

 

You first need to select which change should be applied for each event to have the button “OK” 

appearing: 
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Then, your modifications will be applied. 
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History / Tracking 
 

You will know who created the event and all events modifications and even deletions 

 

Activation and creation of the new menu “History” 
 

From the menu Tools -> Options -> Event activate the option “Save the history of events modifications”: 

 

 
Then, you will have a new entry “History” from the menu “Tools”. 

 

NB: Note that this new menu can lower speed performances of PlanningPME as it records all creations, 

modifications and deletions within PlanningPME. We advise you to copy and then purge your data 

regularly. 

 

 

Information available on the “History” menu 
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This window shows all creations, modifications and deletions done on an event, project, client and 

resources with that different information: 

 

Date Hour: Date of the operation 

Operation: Type of the operation: Creation, update or deletion 

Type: Task, unavailability, resource, client, resource 

Begin: Task/unavailability beginning date and time 

End: Task/unavailability ending date and time 

Label: Label of the task, resource, client, project or resource 

Key:  ID 

User: User login if activated 

 

Functions available within this new window 
 

Filter the list easily 

Type the keyword on the filter and the results will be filtered rapidly. 



 

Tutorial PlanningPME Desktop version  - 195 - 

 

 

 

Order the list chronologically: 

Click on the top of each column to order the list as you want. 

Purge the list: 

Too many data here can lower your planning. You can purge regularly the results here so that next time 

you connect to this menu, the list will be shorter and will be displayed more rapidly 

 

 

Copy the list: 

Copy / paste the results to an external file like Excel via a button  

 

 

Users rights permissions 

The access to the new menu can be allowed or not within users permissions. 

Indeed, if the user does not have the permission, he will not be able to see the report. 

 

 

Data tracked 
 
History of an event 

Assigning access rights to your users, you will know the tracking for each events:  creation date and all 

modifications done.  

This information appears when you click at the left bottom side of the event window on “History”.  
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Then, details on this event will show: 

 
 

History of a client 

All creations and modifications on clients can be tracked when you click on “History” at the left bottom 

side of the client window. To track the deletion of a client, you will need to go to the menu History 

directly. 
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History of a resource 

All creations and modifications on resources can be tracked when you click on “History” at the left bottom 

side of the resource window. To track the deletion of a resource, you will need to go to the menu History 

directly. 

 

History of a project 

All creations and modifications on projects can be tracked when you click on “History” at the left bottom 

side of the client window. To track the deletion of a project, you will need to go to the menu History 

directly. 
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Advanced data settings 
 

Contexts management 
 

We now have a new kind of event named "context" that allow you to add another dimension to the 

schedule. Indeed, you can define where your employees work every days and then, within the context, 

you can schedule appointments. For example, if you need to manage medical appointments with doctors 

on different hospitals, you can first define on which hospital each doctor should work each day and then, 

create appointments within this context. 

 

 
 

Activate contexts 
 

First, activate the option from the menu Tools -> Options -> Data and select "Activate as".  

 
 

You now have a menu "Context" under "Data". 

 
Add, modify or delete the list of contexts 
 

To define a new context, press the button "Add". 
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You can then type a label for example "Hospital Chocolate" and define if this new context will be available 

for all departments or only some of them. So, on the planning, if you have writing rights on one 

department only, then only contextss defined for this department will be available while creating a new 

"context" on the planning board. 

 

 
To change the text and background color, select the label on the list and change the colours directly from 

the "text" and "background" colours buttons at the bottom of the window. 

To modify a context, double click on it on the list or right click and select "Modify". 

To delete a context, select it from the list and then press "Delete". 
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Create, modify or delete a context 
 

On the schedule, a context will be represented by a colored rectangle with dash dots as lines. To create a 

new "context", right click on the planning board and select "New context". 

 

 
 

The "Context" window will then open. You can select a label on the drop down list or type directly a new 

label here. If you type a new label, it will be recorded on the menu Data -> Context. 

Then, you can define beginning and end dates and time and even create a recurrent event if needed. 

You can now see that employee Mark will work at hospital Alpha on that day: 

 
 

To modify a context, right click on it and select "Open". 

To delete a context, right click on it and select "delete". 

To copy a context, right click on it and select "copy" and then paste it with a right click and then "Paste" 

on another day and/or resource. 

Display contexts of a department only 
 

As mentioned earlier, you can define a context to one or more departments. Then, when filtering on one 

department on the planning board, when you create a new "context" only contexts of this department will 

appear on the drop down list. 
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Intuitive typing 
 

Intuitive typing is also activated on the drop down list of contexts. When typing the beginning of a label, 

the program now suggests some of the labels pre-registered in order to save time. 

 

Create some events and appointments within a context 
 

You can then create some new appointments within this context drawing a box with your mouse. 

 

 
 

 

 

 

Access rights to contexts defined per user 
 

With the users rights management, you can define who can manage contexts: add, modify or delete rights. 
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Events dependencies – Gantt chart 
 

It is possible to manage events dependencies with PlanningPME and to precise a delay between each 

event. 

Visualisation on the planning: 

 
When an event is shifted on the planning, the following linked events are shifted as well. 

 

Activate this option 
 

Option to activate in the menu Tools -> Options -> Event and select “Events dependencies”. 

 
 

Add, modify, delete a link 
 

Create a link 

-> Right click on the events 

Go to the first event, right click, select Link 
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Then, go to the second event and select …to 

 
 

Results: 

 

 
The black arrow shows that the events are linked. 

 

Delete a link 

Click on the arrow directly and select delete: 

 
 

You can also remove a link easily in PlanningPME from the “Successors” window of the event: 
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Define a delay between the events 
 

You can also precise a delay between two events clicking on the arrow. This windows appears: 

 
When a delay is specified, the arrow colour changes from black to red. 

 

 
 

 
Visualize the direct successors of an event 
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When you open an event, you now have a tab “Successors” that show you all the direct successors of an 

event: 

 
 

NB: You cannot add or delete any links from here. 

 

 

 
 
 
Hide the links on the planning board 
 

You can hide the links if your planning is too crowded via the command CTRL + L. then, this icon will 

appear on your event linked: 

 
 

Shift events on the planning board 
 

Rules while shifting an event 

1 -> While shifting an event in the future, previous events are not shifted. Only successive events are 

shifted. 

2 -> While shifting an event in the past, previous and next events are not shifted. If you shift an event in 

the past and you do not respect the delay specified with the previous event, the software will not let you 

shift it.  

3 -> If a delay is specified, the delay is kept while shifting an event. 

4 -> While shifting an event, there is no search for availability: if the resource already has an event 

assigned, there will be two events displayed for the same day. 

 

Example: 
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5 -> While shifting an event, there is no search for availability: if the resource already has an event 

assigned, there will be two events displayed for the same day. 

Example 

 
 

 
 

On the example above, when we shift the green event: 

 

- The brown event is shifted as well as it is a successive event 

- The yellow event do not move as it is a previous event 

 

 

Events template 
 

Definition of a template 
An events template is a list of events with different durations and linked information like delay between 

events.  
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Within some industries like manufacturing, garages, calling predefined events templates are necessary 

when having a new job to complete in order to save time avoiding creating one by one the events 

allocated to one type of job. 

 

Create a new template 
 

Go to the menu Data -> Templates and click on "Add". 

 
 

Label: Give a name to your template 

 

Unit: Select the unit for your events: Minutes, hours or days 

  
This unit will then be applied for the event duration and the delay between two events. 
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N°: This is the event number 

 

Task: Select your task on the drop down list. This list is the one you have on the menu “Data” -> “Tasks” 

 

 
 

 

 

 

Duration: Specify the duration for each task 

 

Predecessor: This field is not mandatory. You can precise here the predecessor of the task giving the 

number of this task. The two tasks will then be linked. In the example below, the task “programming” is 

linked to the task “Analysis”: 

 

 
 

 

Delay: Delay between this event and its predecessor. This field is not mandatory. When you specify a 

delay, it appears in red on the planning board. In the example below, the task “programming” is linked to 

the task “Analysis” and the delay is 2 days: 

 

 
 

 
 

 

Resource: This field is not mandatory. You can assign each event to a resource by default. Then, while 

putting your template in production on the schedule, each event will be allocated to a resource by 

default: 
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You then have this kind of events template: 

 
 

You can create as many templates as you want: 

You can see the duration for each template that is the sum of the duration for all the events of one 

template. 

 

Note that you can copy an already existing template in order to save time. To do so, just select the 

template and press “Copy”. The template will then be copied and you can adjust it and rename it. 

 

 

 

 

Creation of a new “job” from a template 
 

Creation  

 

In the planning board, right click and select “template”. Then, the list of all your templates will 

be displayed and you can select one of them. 

 

 

 

Then, this creation window appears: 
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You can specify the following information: 

 

- Project Name 

- Template 

- Client Name 

- Resource name: Only one resource can be assigned. 

- Beginning date: the end date is calculate automatically from the events template. 

- Comments 

 

Then, in a first time, on the planning board, only one first event will be drawn: 

 

 

Production  

Then, once you want to put your new job in production, you just need to right click and then select 

“Production”: 

 

Your job will be divided into the different events you defined in the template. 

Then, you can assign the different events to your resources and adjust your schedule. 

 
 
Create all jobs directly while assigning the template 
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You can activate this option in order to create all the events directly skipping the step 

“Produce”. 

 
 

Rename “Template” and “Production” 
 

In order to adapt PlanningPME to your activity, you can rename the label "Template" and "Production" 

from the menu "Tools" -> "Labels and format" 

 

 

 

Hide links 
 

You can also hide the links of your schedule pressing the keys « CTRL + L » in order to have a good 

overview of your schedule. 
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Assign all events to one resource 
 

If you need to shift all the events into one resource, just right click on one of the linked event and select 

“Assign to”. Then, all events will be assigned to the resource selected. 

 

 

Delete one event or all linked events 
You can decide to delete either one linked event or all the events linked. 

To do so, right click on the event and select “Delete”: 

 

Then, you will get this message: 

 

 

 

if you press “Yes”, all the events linked will be 

deleted. 

If you press “No”, only the event selected will be 

deleted. 

 

 

Advanced IT functions 
 

Synchronization with Outlook 
 

You can synchronize both ways from PlanningPME to Outlook and from Outlook to PlanningPME. 

 

Activation of this option 
 

From PlanningPME, go to the menu « Tools » -> « Options » -> « Outlook ». The following window appears. 
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Tick on the box « Authorize synchronization with Outlook ». 

 

 

Fields 

Select the fields you want to synchronise clicking on the button “Fields” 

 

 

Do not synchronise events older than 

Select the time period: All events older will not be synchronised. 

 

Frequency 

Choose the synchronization frequency - Minimum: 5 minutes 

 

You are 

Precise who you are: Choose on the list of human resources your name. Events created for this resource 

selected will be synchronized to your Outlook. 
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Select the different options of synchronization from Outlook to PlanningPME: Do you want to synchronize 

all appointments and/or all events from Outlook to PlanningPME? 

Select the different options of synchronization from PlanningPME to Outlook: Do you want to synchronize 

all events to Outlook Calendar or Outlook Events? 

 
From Outlook to PlanningPME 
 

You can synchronize all appointments and / or events from Outlook to PlanningPME. 

 

Description 

 

 
 

Careful: All your events and / appointments will be imported the first time you activate this 

option. Make sure you really want to activate this option. 

 

 

Fields Synchronized 

 

. Events marked as « Private » are not synchronized. 

 

 

. Events not marked as “Private” are synchronized. Here are the details on the fields synchronized: 

 

 Outlook PlanningPME 

Field 1 Subject Label 

Field 2 Starting Date and Time Beginning Date and Time 

Field 3 End Date and Time End Date and Time 

Field 4 Comments Comments 

Field 5 Reminder Reminder like shown here: 

 
 

EXCEPT IF the option “Event reminder using a 

date” is activated on the menu “Tools” -> 

“Options” -> Event 

 
In that case, the reminder will not be synchronized. 

 

 

Behaviour of the synchronization 
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Action in Outlook Consequence in PlanningPME 

Creation of an event in Outlook Calendar Creation of an event if the option “Synchronize 

all appointments” is selected 

Creation of an event in Outlook Creation of an event if the option “Synchronize 

all events” is selected 

Modification Modification 

Deletion Deletion 

Creation of a recurrent booking Nothing created 

Creation of a private event No event created 

 

See point IV.4 to learn about the behaviour of the synchronization if users rights are activated. 

From PlanningPME to Outlook 
 

Synchronization of all the events 

 

You can synchronize all events from PlanningPME to Outlook appointments or events. 

 
The events will be synchronized automatically to Outlook Appointments OR Events. 

You also have the possibility to select task by task whether you want to send them to Outlook tasks or 

appointments. See next chapter. 

 

Synchronization task by task 

 

To decide task by task which ones will be sent to Outlook, do not activate this option below: 

 
 

Then, on the planning board, for each task, you can decide if you want to synchronize them to Outlook 

task or appointment with a right click, Outlook -> Synchronize to tasks or appointments. 

 

You can also decide to stop the synchronization event by event with a right click -> Outlook -> Stop the 

synchronization. 

 

 

Fields Synchronized 

 

. NB: Only events are synchronized. Unavailabilities are not synchronized. 

The reminder is also synchronised: 
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NB: If the option “Event reminder using a date” is activated, the reminder will not be synchronized in 

Outlook. 

 

 

Behaviour of the synchronization 

 
Action in PlanningPME Consequence in Outlook 

Creation of an event Creation of an event  

Modification of an event Modification 

Deletion of a task Deletion 

Creation of an unavailability Nothing created 

Creation of a periodical event Nothing created 

Event gotten off the recurrence Creation of an event or an event 

 

 

 

Behaviour of the synchronization when users rights are activated 
1st scenario - Users permissions: Reading access but not writing access 

Menu Data -> User 

 
 

This user can visualize all departments but do not have writing access to the departments. 

It means that he is not allowed to add, modify or delete anything on the schedule. 

 

So, if he tries to make some changes on his Outlook, here is the behaviour of the synchronization: 

 

Action in Outlook Result 

Creation of an event or an event in Outlook Nothing created 

Modification of an event or event in Outlook No changes in PlanningPME – At the next 

synchronization, the event modified will be back to its 

initial place. 

Deletion of an event or event in Outlook No changes in PlanningPME – At the next 

synchronization, the event deleted will be back. 
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2nd scenario - Groups permissions on the Event field 

Menu Data -> Group 

 

 
 

The rights selected for the Event (Add, Modify, Delete) will be applied while synchronizing. 

Master Data 
 

If an event is modified both in Outlook and PlanningPME, the latest modification will be taken into 

account. 

With this synchronization, you will save time avoiding a double typing of your appointments and other 

events.  

 

Description of the comments in Outlook 
 

Now, you can select the fields you want to have on the comments while synchronizing your events with 

Outlook from the button “Fields”. 

 
 

If you select some fields here, the comments box in Outlook will show the fields you selected. 

 

If you do not select anything on the outlook description, the comments in PlanningPME will be 

synchronized with the comments in Outlook. Otherwise, if selecting some fields and that you add some 

more comments in Outlook, the updates will not be done from Outlook to PlanningPME. PlanningPME 

description will always be the master data. 
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Import / Export of data from PlanningPME 
 

You can Import / Export data on clients, events and unavailabilities under special txt format from the 

menu File -> Import or Export. 

 

 

Import 
 

It is possible to import clients, events or unavailabilities under text format with tabulation as separator. 

NB: To work with Excel files, you will first have to convert your Excel file under text file. 

 

Import your clients 

From PlanningPME, go to the menu "File" -> "Import" -> "Clients" 

Upload your text file clicking on the arrow of the window below. 

Associate the corresponding fields selecting the available fields on the left and the base field on the right. 

 
Then click on "Import". 

 

 

Import events or unavailabilities 

The set up to import events or unavailabilities is more complex than for clients. Indeed, your text file 

must have a precise format. 

The events will be created automatically on the schedule if your text file is correct. 

 

Format type of the text file: 
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For more information on this type of import, you can contact our technical team: 

support@planningpme.com 

 

Export 
 

You can export your clients, events and unavailabilities under text files. 

From PlanningPME, go to the menu "File" -> "Export". 

 

Clients export 

Enter the name of the file exported and save. 

The exported file looks like this text file: 

 
 

Events or unavailabilities export 

Give the period of time you want to export. 

 
 

Click on "Export" and save your text file. 

The exported file looks like this text file: 
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Functions for IT specialists and developers 

 

Performances of the database 
 

We now have more information on the performances of PlanningPME from the Menu File -> Database -> 

Performances. 

 
It allows to have an idea of the performances of the database on loading, calculation, number of data. 

 
Improve performances 
 

Also, to increase your planning performances, if not done yet, we highly advise you to migrate from MS 

Access to SQL Server database. Contact Target Skills for more information. 

 
Have your database hosted on Target Skills servers 
 

If you want Target Skills to host your database and assume the full maintenance on your system, you can 

now have your database hosted on our server. We invite you to contact your sales contact in order to have 

more information. 

 

Scripts execution 
 

You can launch some scripts while launching or charging PlanningPME. You can add them from the menu 

Tools -> Options -> Advanced. 
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Charging PlanningPME =Creation, modification or deletion of an event on the planning board. 

 

Launch of the schedule with criteria 
 

Ex1: planningpme  

/date=1/1/2009 /filter=Administration /planning=Monthly  

/view=resource /[champ sup]=[value]. 

 

Ex2: planningpme /base=Driver={Oracle in O 

raHome92};DBQ=PLANNING;UID=PLANNING;  

 

PWD=PLANNING /oledb=1 /schema=PLANNING. /fr=0 /us=0 

 

 
Object model PlanningPME COM 
 

You have the possibility to make links between your databases and /or management softwares and 

PlanningPME.   

- PlanningPME COM: http://www.planningpme.com/object-model-planningpme.htm  

 

As an example, you can import your existing client database in PlanningPME and, then, you can 

synchronize regularly those databases. you avoid double typing! 

PlanningPME COM allows you to integrate PlanningPME into your data system. 

 

Plugin PlanningPME 
 

Why a plug-in PlanningPME? 

 

- In order to insert controls (button) in the PlanningPME interface and associate actions. 

- In order to make automatic actions for example add or update an event.  

http://www.planningpme.com/object-model-planningpme.htm
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